Support Portal/Ticketing System Issue
Resolved
Our support portal (https://utrgv.edusupportcenter.com/) is now fully functional. You are welcome to create cases via the web form, use Chat, Telephone support, or search for answers in our knowledgebase. For Telephone Support, contact our 24/7 COLTT Help Desk at 956-665-5327 or 956-882-6792.
Posted Dec 22, 2021 - 14:27 CST
Investigating
Our support portal (http://utrgv.edu/coltthelp) is currently experiencing technical issues with submitting tickets. The only way to submit cases will be through the “Blackboard Support” button within Blackboard. You are welcome to use Chat, Telephone support, or search for answers in our knowledgebase. For Telephone Support, contact our 24/7 COLTT Help Desk at: 956-665-5327 (Edinburg) / 956-882-6792 (Brownsville).
Posted Nov 22, 2021 - 10:26 CST
This incident affected: COLTT Ticketing System.