Blackboard Collaborate Ultra - Scheduled Maintenance
Completed
The scheduled maintenance has been completed.
Posted Sep 10, 2020 - 05:00 CDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 10, 2020 - 01:00 CDT
Scheduled
On Thursday, September 10, Blackboard Collaborate Ultra will be upgraded to the latest release. This upgrade will occur from 1:00 am to 5:00 am CDT. Blackboard engineers will try to minimize downtime and do not plan on using the entire maintenance window. However, they will use the entire maintenance window if necessary. Collaborate Ultra users will experience intermittent availability during this maintenance window.
Posted Aug 26, 2020 - 21:28 CDT
This scheduled maintenance affected: Blackboard Collaborate Ultra.