Respondus Lockdown Browser Issues
Resolved
AWS service degradation issue has been resolved. As a result, Respondus Lockdown Browser is now fully operational. This outage affected the performance of Respondus on Nov. 25th from 8 a.m. to Nov. 26th at 12:30 a.m. approximately.
Posted Nov 26, 2020 - 08:37 CST
Update
Respondus Lockdown Browser is currently experiencing a severe slowdown/outage related to AWS outages in US-East. This outage is widespread and affecting many institutions. We will provide updates as we have them.
Posted Nov 25, 2020 - 13:46 CST
Identified
We are aware of a Respondus Lockdown Browser slowdown this morning and Respondus engineers are working with AWS to resolve this issue.
It is not recommended to begin a quiz/exam during this maintenance window as you may be kicked out of Blackboard and your quiz/exam.
Posted Nov 25, 2020 - 09:31 CST
This incident affected: Respondus Lockdown Browser and Monitor.