Blackboard Collaborate Ultra Recordings
Resolved
AWS service degradation issue has been resolved. As a result, Blackboard Collaborate is now fully operational. This outage affected the performance of Blackboard Collaborate on Nov. 25th from 8 a.m. to Nov. 26th at 12:30 a.m. approximately.
Posted Nov 26, 2020 - 08:40 CST
Identified
AWS is having issues with several services based out of US-East-01. Blackboard has identified that these AWS issues are causing processing delays in Blackboard Collaborate Ultra Recordings.
Posted Nov 25, 2020 - 17:41 CST
This incident affected: Blackboard Collaborate Ultra.