Blackboard Learn - Scheduled Maintenance
Completed
The scheduled maintenance has been completed.
Posted Sep 05, 2021 - 05:00 CDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 05, 2021 - 01:00 CDT
Scheduled
Blackboard Learn may experience periods of service disruption due to scheduled infrastructure/database maintenance. Blackboard will make all efforts to keep any service disruption within the defined window to a minimum. This maintenance is required to improve the performance and functionality of the Blackboard learning management system.
Posted Aug 30, 2021 - 12:00 CDT
This scheduled maintenance affected: Blackboard Learn.