Blackboard Collaborate Ultra - Scheduled Maintenance
Completed
The scheduled maintenance has been completed.
Posted Nov 11, 2021 - 05:00 CST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 11, 2021 - 01:00 CST
Scheduled
On Thursday, November 11, between 1:00a.m. and 5:00a.m. (CST), Blackboard Collaborate Ultra will be undergoing scheduled infrastructure maintenance. This maintenance window will provide improvement to Collaborate's stability and performance.

Blackboard strongly recommends not using Collaborate Ultra throughout this maintenance window, even if the site is up and running. Collaborate Ultra users will experience intermittent availability during this maintenance window.
Posted Nov 10, 2021 - 16:11 CST
This scheduled maintenance affected: Blackboard Collaborate Ultra.