Blackboard Learn System is Down
Resolved
Blackboard Learn is fully operational. Blackboard engineers have resolved the issues affecting the learning management system performance. If you have any questions or issues, please contact the COLTT Help Desk at (956)665-5327 or (956)882-6792.
Posted Sep 07, 2022 - 13:06 CDT
Investigating
Blackboard Learn is currently down. Blackboard engineers are investigating the issue.
Posted Sep 07, 2022 - 12:47 CDT
This incident affected: Blackboard Learn.